WonderCSS

jQuery 2.0傲娇姿态,不再兼容IE6/7/8,国内的前端们蛋疼了

每一只前端们都需掌握三大利器:HTML、CSS、JS!在JS众最熟悉的 jQuery 开启了2.0新版本,并且傲娇宣布不再兼容IE6、7、8旧版本浏览器了。可是,面对国内多数使用IE6/7/8的网站前端们开始蛋疼了,因为我们的“国情”总是有些脱节,不是么。

经过 10 个月的开发 jQuery 2.0 版本现在正式发布了。jQuery 团队将 2.0 版本为现代浏览器定制和优化,兼顾移动设备,放弃了对 IE 旧版本的兼容,体积相比 1.9.1 减小了 10%,运行效率也会更高。jQuery 1.9.x 版本仍将继续维护更新,希望兼容所有浏览器的网站可以选择不升级 2.0 版本。

jQuery-2-0

下面是 2.0 版本的一些特性:

不再兼容 IE6/7/8

需要注意 IE9、IE10 的兼容模式仍然会使 jQuery 2.0 运行不正常,需要在 HTTP header 指定 X-UA-Compatible 属性,或者在页面 meta 标签中声明(性能原因,不推荐后者);

体积更小

移除 IE6/7/8 兼容所需的代码,jQuery 2.0 体积减小了 10%,并且会根据 Android 2.x 版本的份额,移除更多兼容性代码,所以不要指望 jQuery 2.0 对旧设备的兼容性。

可自定义包含的功能模块

通过配置应用所需的功能函数,可编译获取指定功能模块的代码版本,更大幅度减小文件体积。

兼容 1.9 版本的 API

如果你的网站应用已经在使用 jQuery 1.9 版本,那就可以直接平滑迁移到 2.0 ,建议使用 jQuery Migrate 插件调试确认。

预计数月内 jQuery 团队会更新推出兼容性更好的 1.x 版本分支的 1.10 ,但由于团队精力有限,1.1x 和 2.0 分支会独立进行,而且更多倾向 2.0 版本的研发,建议开发者尝试和使用 2.x 最新版。

By 于湛 发布于 2013.04.19 1,609 次浏览

发表评论

电子邮件地址不会被公开。 必填项已用*标注